読者です 読者をやめる 読者になる 読者になる

ruby-opencvがRuby 2.0で使えるようになりました

というわけで

気がついたらだいぶ時間が開いてしまいましたが、ようやくRuby 2.0に対応しました。

ruby-opencv | RubyGems.org | your community gem host

動作環境は

  • Ruby 1.9.3, 2.0.0
  • OpenCV 2.4.5

となっております。 例によってWindows用にはmingw32,mswin32用のコンパイル済みパッケージも用意してあります。

Ruby 2.0対応以外の変更点は、バグ修正やFat gem作成機能追加ぐらいなので、そろそろ新しい機能も入れたいところですね。 中途半端に手を付けたFaceRecognizerを次回ぐらいで入れたいなー、 などと考えております。あとはリファレンスも進めなければ…。

開発は以下のリポジトリでやっていますので、お気づきの点やご要望、イケてるPull Requestなど、お待ちしております。

ruby-opencv/ruby-opencv - GitHub